Issue for reservation installation

Laraship QuestionsCategory: TechnicalIssue for reservation installation
CT asked 2 weeks ago

Hello,

I have this issue :

Problem 1

  • openspout/openspout[v3.4.0, ..., v3.7.4] require php ~7.3.0 || ~7.4.0 || ~8.0.0 || ~8.1.0 -> your php version (8.3.6) does not satisfy that requirement.
  • Root composer.json requires openspout/openspout ^3.1 -> satisfiable by openspout/openspout[v3.4.0, ..., v3.7.4].

2 Answers
laraship Staff answered 2 weeks ago

Hello,

Please use php 8.2 , php 8.3 will be available on August with latest Laravel version

CT replied 2 weeks ago

I try with php 8.2.20 . The issues is not solved 🙁 .
Problem 1
– openspout/openspout[v3.4.0, …, v3.7.4] require php ~7.3.0 || ~7.4.0 || ~8.0.0 || ~8.1.0
-> your php version (8.2.20) does not satisfy that requirement.
– Root composer.json requires openspout/openspout ^3.1 -> satisfiable by openspout/openspout[v3.4.0, …, v3.7.4].

Should i try with the version 8.1 ?

Regards

laraship Staff replied 2 weeks ago

did you use the githib composer package ?

CT replied 2 weeks ago

On github composer.json in Coral/core/Foundation is :
{
“require”: {
“doctrine/dbal”: “^2.5”,
“spatie/html-element”: “^1.0”,
“yajra/laravel-datatables-buttons”: “^10.0”,
“laravel/passport”: “^11.0”,
“league/csv”: “^9.6”,
“php”: “>=7.1.3”,
“illuminate/support”: “>=5.6”,
“illuminate/view”: “>=5.6”,
“facade/ignition-contracts”: “^1.0”,
“bkwld/cloner”: “^3.9”,
>>>>> “openspout/openspout”: “^v4.16.0”
},
“require-dev”: {
“barryvdh/laravel-ide-helper”: “^2.4”,
“orchestra/testbench”: “v8.10.1”,
“php-coveralls/php-coveralls”: “^2.0”,
“spatie/phpunit-snapshot-assertions”: “^4.2.4”
}
}

in my composer downloaded, composer.json is : {
“require”: {
“doctrine/dbal”: “^2.5”,
“spatie/html-element”: “^1.0”,
“yajra/laravel-datatables-buttons”: “9.*”,
“laravel/passport”: “^10.0”,
“fruitcake/laravel-cors”: “^2.0”,
“league/csv”: “^9.6”,
“php”: “>=7.1.3”,
“illuminate/support”: “>=5.6”,
“illuminate/view”: “>=5.6”,
“facade/ignition-contracts”: “^1.0”,
“bkwld/cloner”: “^3.9”,
>>>>> “openspout/openspout”: “^3.1”
},
“require-dev”: {
“barryvdh/laravel-ide-helper”: “^2.4”,
“orchestra/testbench”: “>=3.6”,
“php-coveralls/php-coveralls”: “^2.0”,
“spatie/phpunit-snapshot-assertions”: “^4.2.4”
}
}

laraship Staff answered 2 weeks ago

Hello,

Thanks for your reply, we;re going to check the downloadable package, meanwhile can you try installing using the Github package

We highly recommend this approach as its easier for you to upgrade and maintain your project

https://www.laraship.com/docs/laraship/installation-instructions/install-via-github/