Amazon upgrade 3.0 with laravel 8.0

Amazon upgrade 3.0 with laravel 8.0

Laraship QuestionsCategory: TechnicalAmazon upgrade 3.0 with laravel 8.0
CT asked 4 weeks ago

Hello gentlemen,
I tried to update amazon module 3.0 with last version and laravel 8, when i used composer update, i have this message :
Problem 1
– exeu/apai-io 2.2.0 requires guzzlehttp/guzzle ~6.0 -> satisfiable by guzzlehttp/guzzle[6.0.0, 6.0.1, 6.0.2, 6.1.0, 6.1.1, 6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.3.1, 6.3.2, 6.3.3, 6.4.0, 6.4.1, 6.5.0, 6.5.1, 6.5.2, 6.5.3, 6.5.4, 6.5.5, 6.5.x-dev] but these conflict with your requirements or minimum-stability.
– exeu/apai-io 2.1.0 requires guzzlehttp/guzzle ~6.0 -> satisfiable by guzzlehttp/guzzle[6.0.0, 6.0.1, 6.0.2, 6.1.0, 6.1.1, 6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.3.1, 6.3.2, 6.3.3, 6.4.0, 6.4.1, 6.5.0, 6.5.1, 6.5.2, 6.5.3, 6.5.4, 6.5.5, 6.5.x-dev] but these conflict with your requirements or minimum-stability.
– exeu/apai-io 2.0.0 requires guzzlehttp/guzzle ~6.0 -> satisfiable by guzzlehttp/guzzle[6.0.0, 6.0.1, 6.0.2, 6.1.0, 6.1.1, 6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.3.1, 6.3.2, 6.3.3, 6.4.0, 6.4.1, 6.5.0, 6.5.1, 6.5.2, 6.5.3, 6.5.4, 6.5.5, 6.5.x-dev] but these conflict with your requirements or minimum-stability.
– Installation request for exeu/apai-io ~2.0 -> satisfiable by exeu/apai-io[2.0.0, 2.1.0, 2.2.0].
I check on website and i think the package is not compatible with laravel 8 yet.

1 Answers
laraship Staff answered 4 weeks ago
Hello,

Version 3 does not use exeu/apai package any more, it should be "revolution/laravel-amazon-product-api": "~4.2" 
can you check composer.json file inside the the module directory
CT
replied 4 weeks ago

<div>Hello, could you check my account https://www.laraship.com/my-account/downloads/ and add in the same time Aliexpress module too (For more information, you could ask more information about this module with Marwan) ?</div>
<div>In module.json  "version": "3.0" is display and in composer.json file   "exeu/apai-io": "~2.0" is display.</div>
<div></div>
<div>Thank you.</div>

laraship
Staff replied 4 weeks ago

Hello
Can you try downloading it again, also we have created a free order for you with AliExpress module to be downloaded from there 🙂

CT
replied 4 weeks ago

Thank you.

Happy New Year!

40% DISCOUNT ON OUR ENTIRE STORE
COUPON CODE : Hello2021
GO TO STORE
LIMITED TIME OFFER
close-link
40% Off on all of LARASHIP platforms, plugins, and themes NO EXCLUSIONS
CODE: Hello2021
close-image